Без Экселя ты Емеля: самые важные функции для SEO

Без Экселя ты Емеля: самые важные функции для SEO изображение поста

Разве может профессиональный SEOшник обойтись без офисного пакета Microsoft Office – в частности, без программы Excel? В ней можно творить, что рука пожелает, но в первую очередь – оптимизировать свою работу и делать за один трудодень больше, чем от вас требуют.

Чтобы не стать «капитаном очевидность», мы решили рассказать вам о тех функциях, которые покрыты занавесом тайны. О них знает очень мало людей, еще меньшее количество пользователей активно их использует. Так что включаем мозг, запускаем Excel – и запоминаем!

  • Функция № 1: ДЛСТР (англ LEN)

Данная функция применяется в основном для определения длины заданного в формуле текста (или текстового содержания ячейки). Применений тому, как вы понимаете, море. Например, заказчик требует, чтобы длина анкоров или же мета-тегов не превышала 70 знаков.

LEN

Для наглядности можно добавить условное форматирование:

Меню

Условное форматирование

А затем делаем так, чтобы все строки с длиной менее допустимого значения были одним цветом, а остальные – другим.

Изменения правила форматирования

Диспетчер правил условного форматирования

В итоге получается вот что:

Страница Microsoft Excel

Может и выглядит не ахти, но зато удобно и наглядно. Особенно если таких мета-тегов у вас накопилось несколько сотен тысяч.

  • Функция № 2: СЖПРОБЕЛЫ (TRIM)

Позволяет удалить все лишние пробелы между словами в содержимом ячейки или заданном фрагменте текста. Очень полезна, если при копировании текста у вас возникли пробелы до, после или между словами. Они могут создать проблемы при последующих обработках.

  • Функции № 3: ПРОПИСН (UPPER), СТРОЧН (LOWER)

Используется в том случае, если вам нужно трансформировать текст в строчные или прописные буквы.

  • Функция № 4: ПРОПНАЧ (PROPER)

Казалось бы, зачем SEOшнику функция, позволяющая трансформировать заглавную букву каждого из слов? Представьте, что вам нужно проверить частотность некой группы ключей, содержащих в себе названия различных компаний. Если будете делать это с помощью основных сервисов, все буквы запроса будут приведены в строчный вид.

Что получится в итоге? Огромная таблица на пару тысяч строк, имеющая вид «ЗАПРОС + КОМПАНИЯ». При этом все названия компаний приведены с маленькой буквы. Неплохо бы привести все это в человечески вид.

Для этого вы разделяете весь текстовый массив на запросы и названия, используя функцию Данные – Текст по столбцам. Затем применяете функцию PROPER к названиям компаний и производите сцепку с первым столбцом.

  • Функция № 5: СЦЕПИТЬ (текст 1; текст 2; текст 3…) (англ. CONCATENATE)

Наверное, одна из самых полезных функций для SEO. Представьте, что вам необходимо отправить в Disavow Links ссылки с 500 далеко не качественных доменов. Его синтаксис предполагает формат вида domain: ваш_домен.com.ua. Конечно, можно прописать все 500 ссылок вручную, но зачем, если у вас есть такая замечательная функция? Потребуется лишь написать =СЦЕПИТЬ (“domain:”;адрес_ячейки), после чего растянуть формулу полностью на весь столбец.

ES1

О пяти уже рассказали, на очереди – еще семь.

  • Функция № 1: СЧЁТЕСЛИ (диапазон; критерий) (англ. COUNTIF).

Поможет подсчитать все ячейки внутри диапазона по конкретному критерию. Представим, что вы бы хотели навскидку оценить разбавленность анкорного листа своего сайта URL. Например, такой:

COUNTIF

Для подсчета процента разбавки введем следующую формулу:

=СЧЁТЕСЛИ(A1:A9;”*domen.ru*”)

ES1

  • Функция № 2: СУМЕСЛИ (диапазон; критерий; диапазон_для_сложения) (англ. SUMIF)

Данная функция работает по такому же принципу, что и в предыдущем примере. Главное отличие заключается в том, что здесь есть два параметра с диапазонами. Первый используется для применения критерия, второй – для сложения значений.

  • Функции № 3: ЛЕВСИМВ (текст; количество знаков) (англ. (LEFT), ПРАВСИМВ (текст; количество знаков) ( англ. RIGHT)

С ее помощью вы вернете заданное количество знаков как слева, так и справа. Обычно эти функции используются в уже устоявшейся связке с функцией поиска.

  • Функция № 4: ПОИСК (искомый фрагмент, просматриваемый текст, начальная позиция) (англ. SEARCH)

А эта функция возвращает номер вхождения подстроки в общую строку. Чтобы вам было понятнее, рассмотрим все это на конкретном примере. Например, вам срочно потребовалось выделить из списка URL-ов домен.

ES16

Итак, мы с вами ищем слеш в ячейке с URL. Как минимум, с восьмой позиции, чтобы исключить все начальные слеши.

=ПОИСК(“/”;ячейка_с_URL;8)

ES16

Выделяем подстроку с одним доменом:

=ЛЕВСИМВ(ячейка_URL;ПОИСК(“/”;ячейка_URL;8))

ES16

Такие вот чудеса!

  • Функция № 5: ВПР (искомое_значение, таблица, номер_столбца, тип_совпадения) (англ. VLOOKUP)

Позволяет «состыковать» значения разных таблиц на основе анализа данных в различных ячейках. В качестве примера возьмем список доменов, анкоров, которые ссылаются на сайт.

ES16

Порядок сайтов разнится, и это очень плохо. Применяем функцию ВПР:

=ВПР(A2;F2:H11;2;ЛОЖЬ)

ES16

Слово ЛОЖЬ означает, что мы с вами пытаемся найти точное совпадение эталонов с содержимым ячейки. ИСТИНА говорит о том, что при отсутствии точного совпадения мы будем использовать ближайшее к нему совпадение по убыванию.

  • Функция № 6: Данные > Удаление дубликатов (Data > Remove Duplicates)

Пожалуй, одна из самых востребованных функций, которая позволит вам очистить свой список от повторений. Кликните на шапке столбца и выделите его целиком. Нужно выделить весь список полностью. После этого вы переходите во вкладку «Данные» и находите там пункт «Удалить дубликаты»:

ES16

ES16

Нажимаем ОК и наслаждаемся отличным результатом работы.

ES16

  • Функция № 7: Данные > Текст по столбцам (Data > Text to Columns)

Последняя функция на сегодня. Поможет Вам разбить различные массивы по отдельным столбцам. А еще с ее помощью можно задать любой разделитель по вашему выбору. (запятая, точка, слеш).

Искренне надеемся, что данные материал спасет вас от рутинной работы и бессмысленной траты времени. Всем хороших новостей и легкой раскрутки, до встречи!

Комментарии
Adblock
detector