Если вы хотите создать свое видео в интернете или обработать уже готовое, тогда наш сайт http://inter-video.com/ вам в этом поможет.

О пяти из них мы уже рассказали в первой части статьи, на очереди – еще семь.

  1. Функция № 1: СЧЁТЕСЛИ (диапазон; критерий) (англ. COUNTIF).

Поможет подсчитать все ячейки внутри диапазона по конкретному критерию. Представим, что вы бы хотели навскидку оценить разбавленность анкорного листа своего сайта URL. Например, такой:

ES1

Для подсчета процента разбавки введем следующую формулу:

=СЧЁТЕСЛИ(A1:A9;"*domen.ru*")

ES1

  1. Функция № 2: СУМЕСЛИ (диапазон; критерий; диапазон_для_сложения) (англ. SUMIF)

Данная функция работает по такому же принципу, что и в предыдущем примере. Главное отличие заключается в том, что здесь есть два параметра с диапазонами. Первый используется для применения критерия, второй – для сложения значений.

  1. Функции № 3: ЛЕВСИМВ (текст; количество знаков) (англ. (LEFT), ПРАВСИМВ (текст; количество знаков) ( англ. RIGHT)

С ее помощью вы вернете заданное количество знаков как слева, так и справа. Обычно эти функции используются в уже устоявшейся связке с функцией поиска.

  1. Функция № 4: ПОИСК (искомый фрагмент, просматриваемый текст, начальная позиция) (англ. SEARCH)

А эта функция возвращает номер вхождения подстроки в общую строку. Чтобы вам было понятнее, рассмотрим все это на конкретном примере. Например, вам срочно потребовалось выделить из списка URL-ов домен.

ES16

Итак, мы с вами ищем слеш в ячейке с URL. Как минимум, с восьмой позиции, чтобы исключить все начальные слеши.

=ПОИСК("/";ячейка_с_URL;8)

ES16

Выделяем подстроку с одним доменом:

=ЛЕВСИМВ(ячейка_URL;ПОИСК("/";ячейка_URL;8))

ES16

Такие вот чудеса!

  1. Функция № 5: ВПР (искомое_значение, таблица, номер_столбца, тип_совпадения) (англ. VLOOKUP)

Позволяет «состыковать» значения разных таблиц на основе анализа данных в различных ячейках. В качестве примера возьмем список доменов, анкоров, которые ссылаются на сайт.

ES16

Порядок сайтов разнится, и это очень плохо. Применяем функцию ВПР:

=ВПР(A2;F2:H11;2;ЛОЖЬ)

ES16

Слово ЛОЖЬ означает, что мы с вами пытаемся найти точное совпадение эталонов с содержимым ячейки. ИСТИНА говорит о том, что при отсутствии точного совпадения мы будем использовать ближайшее к нему совпадение по убыванию.

  1. Функция № 6: Данные > Удаление дубликатов (Data > Remove Duplicates)

Пожалуй, одна из самых востребованных функций, которая позволит вам очистить свой список от повторений. Кликните на шапке столбца и выделите его целиком. Нужно выделить весь список полностью.

После этого вы переходите во вкладку «Данные» и находите там пункт «Удалить дубликаты»:

ES16

ES16

Нажимаем ОК и наслаждаемся отличным результатом работы.

ES16

  1. Функция № 7: Данные > Текст по столбцам (Data > Text to Columns)

Последняя функция на сегодня. Поможет Вам разбить различные массивы по отдельным столбцам. А еще с ее помощью можно задать любой разделитель по вашему выбору. (запятая, точка, слеш).

Вывод. Искренне надеемся, что данные материал спасет вас от рутинной работы и бессмысленной траты времени. Всем хороших новостей и легкой раскрутки, до встречи!

 

 

Добавить комментарий


Яндекс.Метрика